upgrade auf debian 8 und brösel dabei

Das Forum für den Linux-Pinguin - auch andere Unix-Derivate (*BSD, (Open)Solaris, Apple's Darwin / MacOS X, ...) sind hier willkommen!
Forumsregeln
Das Forum für den Linux-Pinguin - auch andere Unix-Derivate (*BSD, (Open)Solaris, Apple's Darwin / MacOS X, ...) sind hier willkommen!

upgrade auf debian 8 und brösel dabei

Beitragvon jutta » Sa 16 Mai, 2015 09:24

ich bin dabei, diverse rechner von wheezy auf jessie upzugraden. der erste war eine minimalistische virtualbox vm (debian, 64 bit, xfce-desktop, firefox und google chrome installiert und sonst nix.) da funktionierte das upgrade erwartungsgemäß völlig problemlos.

der 2. war wieder eine virtualbox vm, diesmal 32 bit debian als gastsystem und ein bissl mehr installiert, aber auch nicht viel. die wollte nach dem upgrade nicht mehr booten. irgendwo war regelmäßig schluss und sie sprang zu der "welcome to emergency mode" meldung - ohne für mich erkennbare fehlermeldung davor. im emergency mode kann man aber nicht viel tun, wenn man nicht weiß, warum es nicht geht. nach ein paar versuchen hab ich beim grub-bildschirm die erweiterten optionen angeklickt und konnte im recovey mode normal weiter booten. dann läuft auch der desktop. sysvinit ging auch, nur normales booten nicht. nach ein bissl googeln und vielen sehr unterschiedlichen treffern fand ich einen, der behauptete, dass er das problem lösen konnte, indem er in /etc/fstab alles auskommentiert hat, außer / und /swap. das ist zwar imo keine echte lösung, da man einträge in fstab ja nicht zum spass eingetragen hat, aber es hat auch bei dieser vbox funktioniert - mit der nebenwirkung, dass ich die shared folder derzeit nicht benützen kann. dafür muss ich noch eine lösung finden.

der 3. rechner ist das notebook, vor dem ich grad sitze. da ist ein bisschen mehr installiert. (viel mehr, anbefangen von sysadmin-programmen wie wireshark, über diverse grafikprogramme, internet, büroprogramme, virtualbox mit mehreren VMs usw, usw). beim upgrade ist mir nur eine meldung aufgefallen:
Code: Alles auswählen
dpkg: Warnung: Altes Verzeichnis »/mnt« kann nicht gelöscht werden: Das Verzeichnis ist nicht leer


aber sonst alles friedlich und ereignislos. bis zum reboot. da war der bildschirm schwarz. reproduzierbar.
nach ein paar hw-resets dann beim booten wieder in die erweiterten einstellungen und den recovery mode und da geht es. allerdings ging das wlan-if nicht automatisch up. (ka, ob das beim recovery-mode immer so ist oder zufall war). jedenfalls schöner desktop, aber mangels internet funktioniert fast gar nix ;) bis ich das problem durchschaute und wlan0 händisch up gestellt habe.

was mich interessieren würde:

gibt es bei jessie eine gravierende neuerung hinsichtlich des mount-vorgangs und des /mnt verzeichnisses? bei den upgrade-hinweisen habe ich dazu noch nichts gefunden. https://www.debian.org/releases/stable/ ... ase-notes/

ok, auf eines bin ich grad selbst gekommen:
https://www.debian.org/releases/stable/ ... s-incompat

es hilft oft schon, wenn man die frage, die einen seit 2 stunden beschäftigt, präzise formuliert ;) für weitere hinweise bin ich trotzdem dankbar :)

//ps: das mit dem auto-mount kann bei der vm im büro der grund sein, aber nicht bei meinem notebook, denn da stehen alle einzubindenden laufwerke auf "noauto" (seinerzeit ausnahmsweise mitgedacht, da die netzlaufwerke ja nicht greifbar sind, wenn ich mit dem notebook unterwegs bin). hier suche ich also weiter nach gründen, warum das default booten nicht möglich ist. und hier springt die maschine auch nicht in den emergency mode, sondern der bildschirm wird schwarz und bleibt so.
jutta
Administrator
Administrator
 
Beiträge: 30295
Registriert: Do 15 Apr, 2004 10:48
Wohnort: wien

Re: upgrade auf debian 8 und brösel dabei

Beitragvon lordpeng » Mo 18 Mai, 2015 16:53

ich kann keine probleme beim upgrade auf jessie nachvollziehen, hab grade 2 server von squeeze nach jessie hoch gezogen, hat eigentlich alles recht gut geklappt, sogar die proprietären firmware files für die netzwerkkarte wurden übernommen

möglicherweise liegts aber auch einfach daran, dass auf den kisten nur das rennt, was gebraucht wird, nicht mehr und nicht weniger :-)
lordpeng
Moderator
Moderator
 
Beiträge: 10093
Registriert: Mo 23 Jun, 2003 22:45
Wohnort: 47.342367N 14.144035E

Re: upgrade auf debian 8 und brösel dabei

Beitragvon jutta » Di 19 Mai, 2015 09:37

> möglicherweise liegts aber auch einfach daran, dass auf den kisten nur das rennt, was gebraucht wird, nicht mehr und nicht weniger :-)

das kann gut sein. insofern sind server viel einfcher als notebooks, auf denen alles installiert ist, was man so für alle hobbies und interessen braucht oder auch nur einmal ausprobieren wollte.

die fehlermeldung mit dem nicht leeren /mnt verzeichnis konnte ich in einer vm reproduzieren. allerdings hatte sie keinerlei folgen. (und in derselben vm kam auch eine meldung, dass /etc/ImageMagick/ nicht gelöscht werden kann, weils nicht leer ist, obwohl ich an dem file selbst sicher nichts geändert habe). warum das notebook mit den defaulteinstellungen nicht bootet, weiß ich noch nicht (und verschieb es auf das pfingstwochenende)
jutta
Administrator
Administrator
 
Beiträge: 30295
Registriert: Do 15 Apr, 2004 10:48
Wohnort: wien

Re: upgrade auf debian 8 und brösel dabei

Beitragvon lordpeng » Di 19 Mai, 2015 09:52

>das kann gut sein. insofern sind server viel einfcher als notebooks, auf denen alles installiert ist, was man so für alle
>hobbies und interessen braucht oder auch nur einmal ausprobieren wollte.
heute ist ein server mit etwas komplexerer konfiguration dran (LDAP auth für webservices am active directory, apache-ssl, ...), aber auch da hab ich eigentlich keine bedenken dass es nicht klappen sollte...
lordpeng
Moderator
Moderator
 
Beiträge: 10093
Registriert: Mo 23 Jun, 2003 22:45
Wohnort: 47.342367N 14.144035E

Re: upgrade auf debian 8 und brösel dabei

Beitragvon jutta » Fr 22 Jan, 2016 21:44

weil ich den thread grad gesehen habe:

broesel an die ich mich noch erinnere: nach dem upgrade hat mein notebook externe festplatten mit ntfs nicht mehr erkannt. zunächst dache ich: ouch, festplatte kaputt. aber es hat auch bei anderen ntfs-platten gestreikt. liegt an einem an sich bekannten bug in ntfs-3g, der aber bei stable nicht mehr repariert wird. abhilfe: das ntfs-3g paket aus sid installieren.

dafür dass sich das hp-notebook beim booten in den aktuellen kernel reproduzierbar komplett aufgehängt hat, fand ich irgendwann nach längerem googeln eine abhilfe: man muss in der grub-config an 2 stellen "radeon.dpm=0" eintragen. [1] (bis dahin war die einzige lösung, in den alten kernel zu booten. damit funktionierte alles mehr oder weniger normal.)

und vorige woche habe ich dann den desktop upgegradet. (lange hinausgeschoben, wegen
Code: Alles auswählen
(Lese Datenbank ... 313657 Dateien und Verzeichnisse sind derzeit installiert.)
und weil etliche VMs drauf laufen und weil der desktop gleichzeitig auch file- und backupserver für die notebooks ist, also funktionieren *muss*. mit einem wort: bauchweh ;)

das upgrade verlief dann recht unspektakulär und es kamen wenige fragen hinsichtlich geänderter configs. (ich habe mir die unterschiede angeschaut und dann immer die neue version des maintainers genommen, weil es leichter ist, meine individuellen wünsche in eine funktionierende neue config reinzutippen als die alte config an noch unbekannte neue defaults anzupassen).

... und nach dem reboot funktionierte der anmeldebildschirm nicht mehr. zuerst graues geflimmer, cursor in linken oberen bildschirmeck, dann in die konsole. zumindest konnte ich also logfiles lesen ;-) mit /etc/init.d/gdm3 start hat sich der anmeldebildschirm und der desktop starten lassen, der neue systemd hat es nicht geschafft.
Code: Alles auswählen
Jan 12 16:25:12 z220 systemd[1]: Unit gdm.service cannot be reloaded because it is inactive.


nach längerem rumsuchen und divesen irrwegen (es gab auch etliche "Could not parse ... file not found" meldungen, außerdem gibts zu gdm3 v 3.14.1 256 bugreports und entsprechend hunderte forenthreads mit lösungen, die irgendwem halfen aber nicht mir) stellte sich raus, dass in meinem fall reste der config einer früheren nvidia-grafikkarte schuld gewesen sind. die pakete selbst waren seit zumindest 2 jahren deinstalliert. nachdem ich die configs mit apt-get remove --purge beseitigt hatte, funktionierte auch der anmeldebildschirm wieder.

die samba-config musste ich auch in ordnung bringen, damit meine Win XP VM für den scanner und die notebooks wieder zu den daten und druckern können. das war einfacher als befürchtet, nur die paar zeilen für meine shares wieder reinkopieren und neu starten. (da es überall seitenlange abhandlungen darüber gibt, was bei samba 4 alles neu ist, hatte ich mir zunächst mehr aufwand erwartet. aber die ganzen neuigkeiten betreffen mich nicht.)

[1] hier genauer beschrieben: https://wiki.debian.org/InstallingDebia ... or%208570p und hier eine lange liste von bugreports und von betroffenen grafikkarten: https://bugzilla.redhat.com/show_bug.cgi?id=1151757
jutta
Administrator
Administrator
 
Beiträge: 30295
Registriert: Do 15 Apr, 2004 10:48
Wohnort: wien


Zurück zu LINUX & UNIX-DERIVATE

Wer ist online?

Mitglieder in diesem Forum: Google [Bot] und 2 Gäste