ubuntu nach win7 installiert, kein Zeichen von GRUB

Das Forum fĂĽr den Linux-Pinguin - auch andere Unix-Derivate (*BSD, (Open)Solaris, Apple's Darwin / MacOS X, ...) sind hier willkommen!
Forumsregeln
Das Forum fĂĽr den Linux-Pinguin - auch andere Unix-Derivate (*BSD, (Open)Solaris, Apple's Darwin / MacOS X, ...) sind hier willkommen!

ubuntu nach win7 installiert, kein Zeichen von GRUB

Beitragvon R4yd3N » Mi 09 Mär, 2011 17:09

Nein, kein Standardproblem bei dem Grub einfach Win7 schluckt, viel spannender und abenteuerlicher. :?

Gestern wollte ich ein Minimalsystem von Ubuntu auf einen Rechner installieren auf dem schon Win7 x64 läuft.
Installation läuft sauber durch, neustart... UND... "Windows is starting"

Kein Lebenszeichen von Grub. Ich habs dann gleich nochmal installiert. Dachte mir vllt habe ich vergessen Grub in den MBR zu schreiben, aber auch danach wars nicht viel besser.

Diesmal hat sich Win7 allerdings beschwert: Hard- oder Software geändert...
-> Normal starten
-> Abgesicherter Modus

Warum weiĂź ich nicht, aber grub scheint auf dem Weg zum MBR zu nah an /dev/null gekommen und reingefallen zu sein :?


Festplatte kaputt? 100MB System Reserved auf der Platte von Win7 schuld?
Google hat mich schon durchgekaut und wieder ausgespuckt. Wer kann helfen?
R4yd3N
Senior Board-Mitglied
Senior Board-Mitglied
 
Beiträge: 459
Registriert: Mi 08 Jun, 2005 19:10

Re: ubuntu nach win7 installiert, kein Zeichen von GRUB

Beitragvon jutta » Mi 09 Mär, 2011 17:17

1. bist du sicher, dass du nur eine einzige festplatte hast und nix in der art von lvm oder so im spiel ist?

2. schau mal, was im bios steht.

zur not gibts auch noch eine moeglichkeit, grub an den windows-bootloader "dranzuhaengen". das hab ich bei win xp schon gemacht, bei win 7 geht das jetzt allerdings ganz anders (und ist mir nicht geglueckt, als ich es voriges jahr versucht habe)

//ps: was in der grub-config steht, waer natuerlich auch interessant. vielleicht wird dort ja per default die windows-partition gestartet. ich weiss jetzt allerdings nicht, wie das file bei grub2 heisst (frueher wars die menue.lst)
jutta
Administrator
Administrator
 
Beiträge: 30300
Registriert: Do 15 Apr, 2004 10:48
Wohnort: wien

Re: ubuntu nach win7 installiert, kein Zeichen von GRUB

Beitragvon R4yd3N » Mi 09 Mär, 2011 17:25

Danke fĂĽr den DenkanstoĂź.

Zu erstens, ja, aber... ich habs von einem USB-Stick aus installiert.

Das probier ich gleich aus, vllt schreibt der böse mir Grub ja auf den, anstatt auf die Festplatte.
Wird beim partitionieren auch als SCSI1(0,0,0) erkannt und die Festplatte als SCSI2(0,0,0).


€dith war da.
Zuletzt geändert von R4yd3N am Mi 09 Mär, 2011 17:32, insgesamt 2-mal geändert.
R4yd3N
Senior Board-Mitglied
Senior Board-Mitglied
 
Beiträge: 459
Registriert: Mi 08 Jun, 2005 19:10

Re: ubuntu nach win7 installiert, kein Zeichen von GRUB

Beitragvon jutta » Mi 09 Mär, 2011 17:27

> Wird beim partitionieren auch als SCSI(0,0,0) erkannt und die Festplatte als (0,0,1).

da stehen die chancen sehr gut, denn 0,0,0 ist ja die "erste festplatte" ;)
jutta
Administrator
Administrator
 
Beiträge: 30300
Registriert: Do 15 Apr, 2004 10:48
Wohnort: wien

Re: ubuntu nach win7 installiert, kein Zeichen von GRUB

Beitragvon R4yd3N » Mi 09 Mär, 2011 18:20

Nach der Installation meldet sich Grub mit einem Geom Error vom Stick.

Ich quäl mich mal durch die Expert Installation, vllt kann man da ja was drehen.
Als USB FDD wird der Stick nämlich leider ned erkannt.
R4yd3N
Senior Board-Mitglied
Senior Board-Mitglied
 
Beiträge: 459
Registriert: Mi 08 Jun, 2005 19:10

[GELĂ–ST] ubuntu nach win7 installiert, kein Zeichen von GRUB

Beitragvon R4yd3N » Mi 09 Mär, 2011 19:09

Es kann so simpel sein.

Installiert man Ubuntu von einem USB Stick aus, der nur als USB-HDD erkannt wird, so arbeitet man die Installation einfach bis vor das Eintragen des Bootloaders in den MBR ab.
Einfach den Stick raus, in der Installationsroutine zurĂĽck zum Punkt Festplatten erkennen und schon installiert sich Grub auf die gewĂĽnschte Platte (vorausgesetzt es ist nur eine verbaut).


Danke jutta.
R4yd3N
Senior Board-Mitglied
Senior Board-Mitglied
 
Beiträge: 459
Registriert: Mi 08 Jun, 2005 19:10

Re: ubuntu nach win7 installiert, kein Zeichen von GRUB

Beitragvon jutta » Do 10 Mär, 2011 10:18

danke fuers feedback und die loesung!

ich denke, dass die auch in zukunft immer wieder gebraucht werden wird, weil es ja immer mehr rechner ohne cd/dvd-laufwerk gibt.

alternativ koennte man auch von einem live-medium (usb-stick, cd, was auch immer zur verfuegung steht) booten und grub von dort aus auf die gewuenschte festplatte installieren. siehe http://wiki.ubuntuusers.de/GRUB_2/Repar ... stallieren

(nach der chroot-methode hab ich es auch schon gemacht, funktioniert problemlos, aber man muss sich halt sicher sein, dass man die festplatten und partitionen richtig identifiziert hat)

ps: danke an dfx und aj, von denen ich das alles gelernt habe!
jutta
Administrator
Administrator
 
Beiträge: 30300
Registriert: Do 15 Apr, 2004 10:48
Wohnort: wien


ZurĂĽck zu LINUX & UNIX-DERIVATE

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 2 Gäste