Debian und Openvpn, Probleme beim Routing (Gelöst)

Das Forum für den Linux-Pinguin - auch andere Unix-Derivate (*BSD, (Open)Solaris, Apple's Darwin / MacOS X, ...) sind hier willkommen!
Forumsregeln
Das Forum für den Linux-Pinguin - auch andere Unix-Derivate (*BSD, (Open)Solaris, Apple's Darwin / MacOS X, ...) sind hier willkommen!

Debian und Openvpn, Probleme beim Routing (Gelöst)

Beitragvon n_1000 » Di 13 Okt, 2009 15:24

Hallo liebe Leute, ich stehe momentan an, hoffe ihr könnt mir weiterhelfen!

Ich bin nach http://www.henningdippel.de/vpn/installation-eines-openvpn-servers/ vorgegangen!
Mein Netz sieht so aus:
Rechner: 192.168.1.0/24
OpenVPN: 10.8.0.0/24

Router= 192.168.1.1
Debian mit OVPN = 192.168.1.6

Ich kann die Verbindung korrekt aufbauen, kann auch den Openvpn Server von der Remote Site aus pingen,
allerdings nicht die Rechner im 192.168.1.0/24 Netz! Laut Anleitung muss hier noch ein Forward auf dem
Router her, den entspchenden Punkt hab ich schon gefunden, nur was eintragen ?

Destination Gateway Subnet Mask Metric Interface Description

kann ich am Router eintragen!
Hoffe ihr könnt mir helfen!

Achja, push route ist in der openvpn konfig eingetragen, und /proc/sys/net/ipv4/ip_forward ist auf 1!
Zuletzt geändert von n_1000 am Di 13 Okt, 2009 20:22, insgesamt 1-mal geändert.
n_1000
Neu im Board
Neu im Board
 
Beiträge: 3
Registriert: Di 13 Okt, 2009 15:18

Re: Debian und Openvpn, Probleme beim Routing

Beitragvon Air20 » Di 13 Okt, 2009 17:52

static routing heisst das zauberwort...

Destination LAN IP : IP des Remote Netzes
Subnet Mask: Subnet Mask des Remotenetzes
Default Gateway: GW = dein OpenVPN Server

that should do the trick...
zumindest bei mir funktioniert es so ähnlich :)

HTH
connected by
xDSL Business silber @16384/1024 flat
inode Etherlink flat @
Bild
und aon Gigaspeed 16 @12352/1024 :rofl:
http://www.youtube.com/watch?v=PtXtIivRRKQ
Air20
Board-User Level 3
Board-User Level 3
 
Beiträge: 1360
Registriert: Fr 16 Apr, 2004 18:32
Wohnort: 2540 Bad Vöslau

Re: Debian und Openvpn, Probleme beim Routing

Beitragvon n_1000 » Di 13 Okt, 2009 18:14

Man kann sich aber auch blöd anstellen :) Vielen Dank für die Antwort, hab einen Denkanstoss in die richtige Richtung gebraucht :D
n_1000
Neu im Board
Neu im Board
 
Beiträge: 3
Registriert: Di 13 Okt, 2009 15:18

Re: Debian und Openvpn, Probleme beim Routing

Beitragvon Air20 » Di 13 Okt, 2009 19:57

n_1000 hat geschrieben:Man kann sich aber auch blöd anstellen :) Vielen Dank für die Antwort, hab einen Denkanstoss in die richtige Richtung gebraucht :D

bitte gib noch bescheid ob es dann auch funktioniet hat ...
Air20
Board-User Level 3
Board-User Level 3
 
Beiträge: 1360
Registriert: Fr 16 Apr, 2004 18:32
Wohnort: 2540 Bad Vöslau

Re: Debian und Openvpn, Probleme beim Routing

Beitragvon n_1000 » Di 13 Okt, 2009 20:21

Ich dachte die Meldung oben hätte das schon ausgesagt :D

Routing Eintrag wie folgt:
Code: Alles auswählen
10.8.0.0   192.168.1.6   255.255.255.0   0   LAN   vpn


Nochmal zu Bestätigung, funktioniert 1a!!! Danke nochmal :)
n_1000
Neu im Board
Neu im Board
 
Beiträge: 3
Registriert: Di 13 Okt, 2009 15:18

Re: Debian und Openvpn, Probleme beim Routing (Gelöst)

Beitragvon Air20 » Mi 14 Okt, 2009 06:22

:ok: ups, hab das irgendwie nicht rausgelesen :)
np
connected by
xDSL Business silber @16384/1024 flat
inode Etherlink flat @
Bild
und aon Gigaspeed 16 @12352/1024 :rofl:
http://www.youtube.com/watch?v=PtXtIivRRKQ
Air20
Board-User Level 3
Board-User Level 3
 
Beiträge: 1360
Registriert: Fr 16 Apr, 2004 18:32
Wohnort: 2540 Bad Vöslau


Zurück zu LINUX & UNIX-DERIVATE

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 11 Gäste

cron